Skip to content
Snippets Groups Projects
  • Felix Gerking's avatar
    mxt-touch: Pull support for atmel mxt touch from dunfell branch · 06ba446b
    Felix Gerking authored and Tobias Kahlki's avatar Tobias Kahlki committed
    * imx6:mxt-touch: Add kernel support for atmel mxt touch
      BCS 746-000886
      (cherry picked from commit 82cbcf67)
    
    * maxTouch:udev: Add udev rule to skip maxTouch fwr loading fallback
    
      The current version of the atmel_mxt_ts driver tries to load a controller
      configuration on each driver probe. However, if no config is provided or
      can't be provided because the driver is built-in, the driver probing process
      is delayed by 60 seconds because of a sysfs firmware load fallback.
      Added a udev rule that automatically cancels the sysfs firmware fallback.
    
      BCS 746-000892
      (cherry picked from commit 55a34692)
    
    * atmel-mxt: convert recipe to new syntax
    06ba446b
Code owners
Assign users and groups as approvers for specific file changes. Learn more.
packagegroup-seconorth-touchdriver.bb 650 B
# Copyright (C) 2014 SECO Northern Europe GmbH
DESCRIPTION = "SECO Northern Europe package group - touch driver"

inherit packagegroup


UNUSED_DRIVERS = " \
	auo-pixcir \
	edt-ft5x06 \
	himax \
	pixcir \
"

RDEPENDS:${PN} = " \
	egalaxi2c \
	ilitek \
	ili2118 \
	scx0500633 \
"

RDEPENDS:${PN}:append:mx6q  = " \
	sis-i2c \
	eetii2c \ 
	ni-force-ts \
"

# This is not used for fng system, so use the override
# this is ugly as the override comes from the distro
# layer. But this hack is ugly anyway an may be
# replaced using the atmel driver instead of the mainline
# driver
RDEPENDS:${PN}:append:seconorth  = " \
	atmel-mxt-skip-fwr-fallback \
"