From baffaef0521327009625077f5cce8a6cf9653009 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Jonas=20H=C3=B6ppner?= <jonas.hoeppner@garz-fricke.com>
Date: Thu, 4 Aug 2022 16:39:49 +0200
Subject: [PATCH] seco-mx8mp: rename machine from imx8mpguf to seco-mx8mp

---
 conf/machine/{imx8mpguf.conf => seco-mx8mp.conf}       |  0
 .../recipes-bsp/imx-mkimage/imx-boot_%.bbappend        | 10 +++++-----
 .../recipes-bsp/imx-mkimage/imx-mkimage_kuk.inc        |  4 ++--
 .../recipes-bsp/u-boot/u-boot-imx_%.bbappend           |  2 +-
 recipes-kernel/linux/linux-imx-kuk_5.10.bb             |  2 +-
 recipes-kernel/linux/linux-imx_5.15.bb                 |  2 +-
 6 files changed, 10 insertions(+), 10 deletions(-)
 rename conf/machine/{imx8mpguf.conf => seco-mx8mp.conf} (100%)

diff --git a/conf/machine/imx8mpguf.conf b/conf/machine/seco-mx8mp.conf
similarity index 100%
rename from conf/machine/imx8mpguf.conf
rename to conf/machine/seco-mx8mp.conf
diff --git a/dynamic-layers/freescale-layer/recipes-bsp/imx-mkimage/imx-boot_%.bbappend b/dynamic-layers/freescale-layer/recipes-bsp/imx-mkimage/imx-boot_%.bbappend
index 12a05d5f..2030405a 100644
--- a/dynamic-layers/freescale-layer/recipes-bsp/imx-mkimage/imx-boot_%.bbappend
+++ b/dynamic-layers/freescale-layer/recipes-bsp/imx-mkimage/imx-boot_%.bbappend
@@ -3,15 +3,15 @@ require imx-mkimage_kuk.inc
 FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
 
 SOC_TARGET:seco-mx8mm = "iMX8MM"
-SOC_TARGET:imx8mpguf = "iMX8MP"
+SOC_TARGET:seco-mx8mp = "iMX8MP"
 SOC_FAMILY:seco-mx8mm = "mx8m"
-SOC_FAMILY:imx8mpguf = "mx8m"
+SOC_FAMILY:seco-mx8mp = "mx8m"
 ATF_MACHINE_NAME:seco-mx8mm = "bl31-imx8mm.bin"
-ATF_MACHINE_NAME:imx8mpguf = "bl31-imx8mp.bin"
+ATF_MACHINE_NAME:seco-mx8mp = "bl31-imx8mp.bin"
 BOOT_STAGING:seco-mx8mm = "${S}/iMX8M"
-BOOT_STAGING:imx8mpguf = "${S}/iMX8M"
+BOOT_STAGING:seco-mx8mp = "${S}/iMX8M"
 MACHINE_SOCARCH_SUFFIX:seco-mx8mm = "-mx8mm"
-MACHINE_SOCARCH_SUFFIX:imx8mpguf = "-mx8mp"
+MACHINE_SOCARCH_SUFFIX:seco-mx8mp = "-mx8mp"
 
 # Using prepuilt bl31 for now
 DEPENDS:remove = "imx-atf"
diff --git a/dynamic-layers/freescale-layer/recipes-bsp/imx-mkimage/imx-mkimage_kuk.inc b/dynamic-layers/freescale-layer/recipes-bsp/imx-mkimage/imx-mkimage_kuk.inc
index 8dfd76c9..e96a18f1 100644
--- a/dynamic-layers/freescale-layer/recipes-bsp/imx-mkimage/imx-mkimage_kuk.inc
+++ b/dynamic-layers/freescale-layer/recipes-bsp/imx-mkimage/imx-mkimage_kuk.inc
@@ -3,5 +3,5 @@ SRC_URI = "git://git.seco.com/seco-ne/3rd-party/kuk/imx-mkimage-kuk.git;protocol
 SRCBRANCH:seco-mx8mm = "kuk_lf-5.10.52_2.1.0"
 SRCREV:seco-mx8mm = "3748257787e25fea042c8e05cfe83cb6938a3f34"
 
-SRCBRANCH:imx8mpguf = "kuk_lf-5.10.52_2.1.0"
-SRCREV:imx8mpguf = "3748257787e25fea042c8e05cfe83cb6938a3f34"
+SRCBRANCH:seco-mx8mp = "kuk_lf-5.10.52_2.1.0"
+SRCREV:seco-mx8mp = "3748257787e25fea042c8e05cfe83cb6938a3f34"
diff --git a/dynamic-layers/freescale-layer/recipes-bsp/u-boot/u-boot-imx_%.bbappend b/dynamic-layers/freescale-layer/recipes-bsp/u-boot/u-boot-imx_%.bbappend
index 69742cc4..2519a109 100644
--- a/dynamic-layers/freescale-layer/recipes-bsp/u-boot/u-boot-imx_%.bbappend
+++ b/dynamic-layers/freescale-layer/recipes-bsp/u-boot/u-boot-imx_%.bbappend
@@ -3,7 +3,7 @@ FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
 # Get include file from poky layer
 FILESEXTRAPATHS:append := "${BSPDIR}/sources/poky/meta/recipes-bsp/u-boot/files:"
 
-COMPATIBLE_MACHINE = "(seco-mx8mm|imx8mpguf)"
+COMPATIBLE_MACHINE = "(seco-mx8mm|seco-mx8mp)"
 
 SRCBRANCH = "guf_imx_v2020.04-trizeps8plus_2021_12_07"
 PV = "2020.04"
diff --git a/recipes-kernel/linux/linux-imx-kuk_5.10.bb b/recipes-kernel/linux/linux-imx-kuk_5.10.bb
index 277d1559..e13ff87c 100644
--- a/recipes-kernel/linux/linux-imx-kuk_5.10.bb
+++ b/recipes-kernel/linux/linux-imx-kuk_5.10.bb
@@ -2,7 +2,7 @@ require linux-seconorth.inc
 
 KERNEL_CONFIG_COMMAND = "oe_runmake_call -C ${S} CC="${KERNEL_CC}" O=${B} olddefconfig"
 
-COMPATIBLE_MACHINE = "(seco-mx8mm|imx8mpguf)"
+COMPATIBLE_MACHINE = "(seco-mx8mm|seco-mx8mp)"
 
 LINUX_VERSION = "5.10"
 LINUX_VERSION_EXTENSION = "-seconorth"
diff --git a/recipes-kernel/linux/linux-imx_5.15.bb b/recipes-kernel/linux/linux-imx_5.15.bb
index ae6f0e19..dd802e1f 100644
--- a/recipes-kernel/linux/linux-imx_5.15.bb
+++ b/recipes-kernel/linux/linux-imx_5.15.bb
@@ -2,7 +2,7 @@ require linux-seconorth.inc
 
 KERNEL_CONFIG_COMMAND = "oe_runmake_call -C ${S} CC="${KERNEL_CC}" O=${B} olddefconfig"
 
-COMPATIBLE_MACHINE = "(seco-mx8mm|imx8mpguf)"
+COMPATIBLE_MACHINE = "(seco-mx8mm|seco-mx8mp)"
 
 LINUX_VERSION = "5.15"
 LINUX_VERSION_EXTENSION = "-seco"
-- 
GitLab