diff --git a/dynamic-layers/freescale-layer/recipes-bsp/u-boot/u-boot-imx/add-u-boot-initial-env-target-to-Makefile.patch b/dynamic-layers/freescale-layer/recipes-bsp/u-boot/u-boot-imx/add-u-boot-initial-env-target-to-Makefile.patch
deleted file mode 100644
index f608b820dd84f406ef4533af1edb8bd79503f7c3..0000000000000000000000000000000000000000
--- a/dynamic-layers/freescale-layer/recipes-bsp/u-boot/u-boot-imx/add-u-boot-initial-env-target-to-Makefile.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From bdaa73a5b3923257add182b4ab8058dbfa33421b Mon Sep 17 00:00:00 2001
-From: Stefano Babic <sbabic@denx.de>
-Date: Wed, 13 Mar 2019 09:46:45 +0100
-Subject: [PATCH] Add target to generate initial environment
-
-The initial environment is linked to the u-boot binary. Modifying the
-environment from User Space with the env tools requires that the tools
-are always built together with the bootloader to be sure that they
-contain the initial environment in case no environment is stored into
-persistent storage or when a board boots with just the default
-environment. This makes difficult for distros to provide a general
-package to access the environment. A simpler way is if the tools are
-generic for all boards and a configuration file is given to provide the
-initial environment.
-
-The patch just generates the initial environment by extracting it from
-the compiled object. This file can then be used for tools in user space
-to initialize the environment.
-
-Signed-off-by: Stefano Babic <sbabic@denx.de>
----
- Makefile | 7 +++++++
- 1 file changed, 7 insertions(+)
-
-diff --git a/Makefile b/Makefile
-index 66a09ac900c..f2c7bb6041a 100644
---- a/Makefile
-+++ b/Makefile
-@@ -1977,6 +1977,13 @@ endif
- 	$(build)=$(build-dir) $(@:.ko=.o)
- 	$(Q)$(MAKE) -f $(srctree)/scripts/Makefile.modpost
- 
-+quiet_cmd_genenv = GENENV $@
-+cmd_genenv = $(OBJCOPY) --dump-section .rodata.default_environment=$@ env/common.o; \
-+	sed --in-place -e 's/\x00/\x0A/g' $@
-+
-+u-boot-initial-env: u-boot.bin
-+	$(call if_changed,genenv)
-+
- # Consistency checks
- # ---------------------------------------------------------------------------
- 
diff --git a/dynamic-layers/freescale-layer/recipes-bsp/u-boot/u-boot-imx/remove-redundant-yyloc-global.patch b/dynamic-layers/freescale-layer/recipes-bsp/u-boot/u-boot-imx/remove-redundant-yyloc-global.patch
deleted file mode 100644
index 2a184e57e2de0b89c70c084f1c5c5967a7fc4f77..0000000000000000000000000000000000000000
--- a/dynamic-layers/freescale-layer/recipes-bsp/u-boot/u-boot-imx/remove-redundant-yyloc-global.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 018921ee79d3f30893614b3b2b63b588d8544f73 Mon Sep 17 00:00:00 2001
-From: Peter Robinson <pbrobinson@gmail.com>
-Date: Thu, 30 Jan 2020 09:37:15 +0000
-Subject: [PATCH] Remove redundant YYLOC global declaration
-
-Same as the upstream fix for building dtc with gcc 10.
-
-Signed-off-by: Peter Robinson <pbrobinson@gmail.com>
----
- scripts/dtc/dtc-lexer.l | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/scripts/dtc/dtc-lexer.l b/scripts/dtc/dtc-lexer.l
-index fd825ebba6..24af549977 100644
---- a/scripts/dtc/dtc-lexer.l
-+++ b/scripts/dtc/dtc-lexer.l
-@@ -38,7 +38,6 @@ LINECOMMENT	"//".*\n
- #include "srcpos.h"
- #include "dtc-parser.tab.h"
- 
--YYLTYPE yylloc;
- extern bool treesource_error;
- 
- /* CAUTION: this will stop working if we ever use yyless() or yyunput() */
--- 
-2.26.2
-
diff --git a/dynamic-layers/freescale-layer/recipes-bsp/u-boot/u-boot-imx_%.bbappend b/dynamic-layers/freescale-layer/recipes-bsp/u-boot/u-boot-imx_%.bbappend
index 371bb7a7d85e4d7d563f1c14e84b0417b08f9051..c41d98f2c1af18003f745a0b419f03bfc7ae73b4 100644
--- a/dynamic-layers/freescale-layer/recipes-bsp/u-boot/u-boot-imx_%.bbappend
+++ b/dynamic-layers/freescale-layer/recipes-bsp/u-boot/u-boot-imx_%.bbappend
@@ -11,17 +11,9 @@ DEPENDS += "u-boot-tools-native"
 
 SRC_URI = " \
     git://git@git.seco.com:4444/seco-ne/3rd-party/kuk/uboot-imx-kuk.git;protocol=ssh;branch=${SRCBRANCH};nobranch=1 \
-    file://add-u-boot-initial-env-target-to-Makefile.patch \
 "
 SRCREV = "${AUTOREV}"
 
-## Keith und Koep u-boot for imx8
-
-# imx8mp
-SRC_URI:remove:imx8mpguf = " \
-    file://add-u-boot-initial-env-target-to-Makefile.patch \
-"
-
 # This is set in poky u-boot.inc to ${PN}-initial-env, which
 # names the file u-boot-imx-initial-env,
 # but fw_printenv expects then name u-boot-initial-env