diff --git a/recipes-seconorth/sharedconf/seco-sharedconf.bb b/recipes-seconorth/sharedconf/seco-sharedconf.bb
index 89238e97dffb2047e64df974c5f2cad6988eb1ea..882e01fe312e4c9abd87d1f90640e1fac469c892 100644
--- a/recipes-seconorth/sharedconf/seco-sharedconf.bb
+++ b/recipes-seconorth/sharedconf/seco-sharedconf.bb
@@ -43,19 +43,20 @@ do_install:append() {
 
 # Note: We used to generate the network configuration upon the first boot.
 # We now support an option for a read-only filesystem, where writing the
-# configuration during the first boot doesn't work anymore. The gf-network-conf
+# configuration during the first boot doesn't work anymore. The network-conf
 # script is still shipped with this recipe, but the execution has been moved
 # to the post-install of the fng-install script (see fng-install/prepare-image).
 
 FILES:${PN} = " \
-    ${sbindir}/gf-conf-reader.sh \
-    ${sbindir}/gf-functions.sh \
+    ${sbindir}/conf-reader.sh \
+    ${sbindir}/seco-functions.sh \
+    ${sbindir}/sys-versions.sh \
     ${sbindir}/gf-versions.sh \
     ${sbindir}/serial2mac.sh \
     ${sbindir}/mac2serial.sh \
     ${sbindir}/sconfig \
     ${sysconfdir}/fng-postinstall/sconfig-init \
-    ${sysconfdir}/init.d/gf-shared-remount \
+    ${sysconfdir}/init.d/etc-shared-remount \
     ${sysconfdir}/shared \
     ${sysconfdir}/udev/** \
     ${systemd_system_unitdir}/** \
@@ -63,25 +64,25 @@ FILES:${PN} = " \
 "
 
 FILES:${PN}-network = " \
-    ${sbindir}/gf-network-conf.sh \
+    ${sbindir}/network-conf.sh \
     ${sbindir}/lan95xx-init-eeprom.sh \
     ${sbindir}/lan95xx-set-mac.sh \
     ${sbindir}/lan95xx-set-serial.sh \
     ${sbindir}/mask2cidr.sh \
-    ${sysconfdir}/init.d/gf-network-conf \
+    ${sysconfdir}/init.d/generate-network-conf \
     ${sysconfdir}/lan9500a-eeprom.bin \
     ${sysconfdir}/lan9514-eeprom.bin \
 "
 
 INITSCRIPT_PACKAGES="${PN}-network ${PN}"
 
-INITSCRIPT_NAME:${PN}="gf-shared-remount"
+INITSCRIPT_NAME:${PN}="etc-shared-remount"
 INITSCRIPT_PARAMS:${PN}="start 10 S ."
 
-INITSCRIPT_NAME:${PN}-network="gf-network-conf"
+INITSCRIPT_NAME:${PN}-network="generate-network-conf"
 INITSCRIPT_PARAMS:${PN}-network="start 80 S ."
 
-SYSTEMD_SERVICE:${PN}-network = "gf-network-conf.service"
+SYSTEMD_SERVICE:${PN}-network = "generate-network-conf.service"
 SYSTEMD_AUTO_ENABLE:fng ?= "enable"
 SYSTEMD_AUTO_ENABLE ?= "disable"