From 1cdbd95903d64e8251b49aa7ef444e193d5ee2b7 Mon Sep 17 00:00:00 2001
From: Tobias Poganiuch <tobias.poganiuch@garz-fricke.com>
Date: Mon, 11 Jul 2022 16:27:22 +0200
Subject: [PATCH] bootscript:dt: Added devicetree description file for i.MX8

Added an description file with the default devicetree for i.MX8
devices.
The file is parsed/used by the post-install scripts to generate
the boot configuration.

BCS 746-000877

(cherry picked from commit 283c6dfbad04132827135106bbc207393337500d)
---
 recipes-bsp/bootscript/bootscript.bb | 10 +++++++++-
 1 file changed, 9 insertions(+), 1 deletion(-)

diff --git a/recipes-bsp/bootscript/bootscript.bb b/recipes-bsp/bootscript/bootscript.bb
index 73d923d1..526ad879 100644
--- a/recipes-bsp/bootscript/bootscript.bb
+++ b/recipes-bsp/bootscript/bootscript.bb
@@ -1,5 +1,5 @@
 SUMMARY = "SECO Northern Europe platform bootscript for FNGBoot"
-HOMEPAGE = "https://www.seco.com"
+HOMEPAGE = "https://north.seco.com"
 
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
@@ -9,6 +9,9 @@ inherit deploy
 RPROVIDES:${PN} += " boot.cfg "
 PROVIDES += " boot.cfg "
 
+RPROVIDES:${PN}:append:mx8 = " devicetree "
+PROVIDES:append:mx8 = " devicetree "
+
 SRC_URI = " \
     file://boot.cfg \
 "
@@ -24,4 +27,9 @@ do_install() {
     install -m 0644 ${S}/boot.cfg ${D}/boot/boot.cfg
 }
 
+do_install:append:mx8() {
+    echo ${DEFAULT_DEVICETREE} >> ${D}/boot/devicetree
+}
+
 FILES:${PN} = "boot/boot.cfg"
+FILES:${PN}:append:mx8 = " boot/devicetree "
-- 
GitLab